3D Printer problems - Monoprice/Wanhao D6

Discussion in '3D Printing' started by ddmckee54, Mar 11, 2020.

  1. ddmckee54

    ddmckee54 Copper

    I've got a Monoprice printer that is actually a re-badged Wanhao D6. I managed to kill my printer last week, I static ZAPPED it - but that's not the only problem. As I was plugging in the SD card to load a new G-code file I felt a shock through my finger tips and the LCD screen went dark at the same time. I remember I said "Oh Fudge", or something like that because those two events occurring at the same time are NEVER a good thing. I tried cycling the power to the printer but that made no difference. I tried the turn it off for a few seconds and then turn it back on trick, still no screen. I tried turning it off for over a minute and then turning it back on but still no joy. By this time it was past my bed-time and I'd run out of the expletives that I've learned in the past 65 years, so I planned on trying it one more time in the morning before I left for work. The next morning, this was Friday, when I turned on the printer the screen came to life. I said Praise Jesus, turned off the printer, and went to work.

    After I got home from work that evening I tried to actually do something with the printer and discovered that I had no cursor on the screen and apparently no way to control the printer. At this point I opened up the printer to see if I could find any part numbers to order replacements. The D6 uses two proprietary PC boards, through my research into these boards I found that they call them the control board and the motherboard. I think the control board is the one that I ZAPPED. It has the SD card hardware, the LCD hardware, and the control knob/button hardware and would have been the first in line when the static charge hit.

    BUT, and it's a big BUT, I also found reference to a relay problem on the motherboard. It seems that Wanhao cloned the motherboard from another of their printers and didn't quite do their due diligence in the design. They used a relay with contacts rated for 10 amps maximum at 30VDC, this is a problem when just the heater load is 12.5 amps. Having designed industrial control systems for over 30 years, I can assure you that relay is going to fail. It's not a matter of IF it's going to fail, it's a matter of when. One of the messages the failure of this relay will generate is a Heater Error message, which I had been getting on rare occasions for several months.

    So my motherboard relay was failing, along with a dead control board. I try to avoid the long shipping delays by buying from suppliers on this side of the pond - no such luck. The only place that I could find that had the control board in stock was Aliexpress. Even with UPS Expedited shipping I won't see my parts until the end of the month at the earliest.

    I'm pretty sure that the only thing wrong with my motherboard is the relay. I have not been able to find a relay that meets the power requirements, both coil and contact. I'm leaning towards using a remote mounted something, either a relay or a DC rated SSR, there's plenty of room available in the base of the printer. The problem I've got is that I think the existing relay has both a NO (Normally Open) contact, and a NC (Normally Closed) contact. I'm not sure if Wanhao is using the NC to do anything. Anybody know if somebody has already gone to the work of figuring out the schematics of the motherboard? I could eventually get it figured out, but if somebody's already done it, why re-invent the wheel?


Share This Page